主图指标公式 买卖提示

主图的指数的准则 买卖提示
1。博弈残忍的

A1: =日期 <= 13181231;

任务线:(EMA(C),14)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;

AA05:马(C),5),LINETHICK3,COLOR0099CC;

五日非常率=(C-AA05)/AA05*100

BB05:=ATAN((AA05/参考文献(A)A05,1)-1)*100)*180/

增速5:=SMA(EMA((AA05-参考文献(A)A05,1)/REF(AA05),1),3)*100,3,1);

增速5:EMA(增速5Rf(增速5)),1)),3),NODRAW;

IF(BB05>30 AND AA05>参考文献(A)A05,1), AA05,DRAWNULL),LINETHICK2,COLORRED;

AA10:马(C),10), LINETHICK0;

AA20:= MA(C),20);

BB10:=ATAN((AA10/参考文献(A)A10,1)-1)*100)*180/

IF(BB05<0 AND AA05<参考文献(A)A05,1), AA05,DRAWNULL),LINETHICK2,COLORFFFF00;

AA30:马(C),30), LINETHICK0;

三挖掘寻找率:(C-AA30)/AA30* 100,NODRAW;

VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>参考文献(A)A20,1) AND AA30>参考文献(A)A30,1);

VAR2:=(AA30-AA20)

BB30:=ATAN((AA30/参考文献(A)A30,1)-1)*100)*180/

强诽谤:=滤网(BB30>30) AND BB10>45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>参考文献(A)A05,1) AND 三放率(三天良好率),1) AND AA10>参考文献(A)A10,1)

AND 加增速5>REF(加增速5),1) AND 增速5>REF(增速5),1) ,10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<参考文献(A)A05,1) AND 三上升率

DRAWTEXT(加仓 ,LOW*,—–添加,COLORYELLOW;

十字架(0),五天补偿率 AND 三上升率参考文献(A)A10,1) ;

缩减:=滤网(JC),10);

计数(穿插(五天补偿率)),0),3)>=1 AND 三放率(三天良好率),1) AND AA05>参考文献(A)A05,1) AND (C/参考文献(C),1)-1)*100>5 AND 参考文献(C),1)

购买行为:=滤网(MR),10);

阻力主题(压缩制紧缩座位),HIGH*,缩减仓库栈。,COLORCYAN;

拖鞋(买买),LOW*,买,COLORYELLOW;

=(高 低 逼近)/ 3

CCI=(典型MA),14)/(* AVEDEV(TYP),14));

穿插(CCI),-100);

VAR6:=CCI>=200;

DRAWTEXT(VAR6,HIGH*,谨慎点。,COLORYELLOW;

SJ:=VAR5;

STICKLINE(SJ,H,L,),COLORYELLOW;

LC:=参考文献(C)LOSE,1);

RSI:SMA(max),0),6,1)/SMA(ABS),6,1)*100;

拉文(十字架)(84),RSI , HIGH,逃脱,COLORGREEN;

VAR3AA:=IF((CLOSE>参考文献(C)LOSE,1)),88,0);

VAR4AA:=IF(((逼近)/(参考文献(C)LOSE,1))>) AND (高)/(近)<) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),45),(低),醒目的地说 ”),COLORYELLOW;

A=(3×C L O H)/ 6

x=(20*a 19*REF(a),1) 18*REF(A),2) 17*REF(A),3) 16*REF(A),4) 15*REF(A),5)+

14*参考文献(A),6) 13*REF(A),7) 12*REF(A),8) 11*REF(A),9) 10*REF(A),10) 9*REF(A),11) 8*REF(A),12)

+7*参考文献(A),13) 6*REF(A),14) 5*REF(A),15) 4*REF(A),16) 3*REF(A),17) 2*REF(A),18)+

参考文献(A),20))/210;

命纹:EMA(X),13),LINETHICK2,COLORMAGENTA;
主图定额准则  均线 - 来生缘 - 来生缘

指数的准则为2。日残忍的线

EMA250:马(C),250),COLORRED;

EMA6:马(C),6),COLORRED LINETHICK2;

EMA18:马(C),18),COLORYELLOW;

EMA55:马(C),55),COLORFF00FF;

EMA144:马(C),144),COLORGREEN;

EMA28 8:马(C),288),COLORBLUE;

中心线[买进] =计数(终结)

CLOSE/EMA18>1.004 AND 穿插(逼近),EMA18) AND EMA18>=

REF(EMA18,1),LINETHICK,COLORRED;

拖曳写信(中心线),LOW*,” 中心线[买进],COLORRED;

VL: = REF(低),1);

VAR12:=(SMA(ABS(LOW-VL),13,(1))/(SMA(max)(低VL),0),13,1))*100;

VAR14:=MA(VAR12,13);

VAR15: = LLV(低),34);

VAR18: = EMA(IF)(低)<=VAR15,VAR14,0),3);

VAR110:=SMA(SMA)(ReX-LLV(低),54)/(HHV(高),54)-LLV(低),54))*100,7,1),5,1);

VAR111:=SMA((CLOSE-低电平(低电平),54)/(HHV(高),54)-LLV(低),54))*100,7,1)**10.9;

T: =拒波器(IF)(VAR111)<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20);

DRAWTEXT(T,,洗碗碟的端,COLORFF00FF;

DRAWTEXT(T,,”|”),COLORFF00FF;

VAR21:=(CLOSE-低电平(低电平),36)/(HHV(高),36)-LLV(低),36))*100;

VAR22:=SMA(VAR21,3,1);

VAR23:=SMA(VAR22,3,1);

VAR24:=SMA(VAR23,3,1);

VAR25:=CROSS(VAR23,VAR24) AND VAR23<20;

DRAWTEXT(FILTER(VAR25,10)=1,,”←抄底”),COLORRED;

DRAWTEXT(FILTER(VAR25,10)=1,,”|”),COLORRED;

VAR29:=CROSS(VAR24,VAR23) AND VAR23>80;

DRAWTEXT(FILTER(VAR29,5)=1,HIGH+,从顶部逃脱,COLORBLUE;

DRAWTEXT(FILTER(VAR29,5)=1,HIGH+,”|”),COLORBLUE;
主图定额准则  均线 - 来生缘 - 来生缘

3.通达信上出下买+三离经叛道的行为主图定额准则

(在附近),17) ABS(MA),17)-REF(MA),17),1));
马:(逼近),17) mA(关闭),17)-REF(MA),17),1);
分水岭:以防(马),17)作业线:分水岭——(EMA(C),3)-分水岭,COLOR00FFFF,LINETHICK2;
PM:马(C),5),COLORWHITE,LINETHICK2;
以防(PM)REF(PM),1),PM,DRAWNULL),COLORRED,LINETHICK2;
以防(PM=REF(PM),1),PM,DRAWNULL),COLORRED;
以防(PM)S:=(PM >买卖线)
D=:分水岭以防(DD),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
以防(S),分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,买卖线),分水岭
买进红箭状物}
A1:=BARSLAST(参考文献(C)ROSS(“
MACD.DIF”,””),1));
B1:=参考文献(C),A1+1)>C AND Rf(,A1+1)<"" AND 十字架(,"");
DRAWTEXT(B1>0,),COLOR00FFFF;{MACD底
离经叛道的行为}
A2:=BARSLAST(参考文献(C)ROSS(“
KDJ.K”,””),1));
B2:=参考文献(C),A2+1)>C AND Rf(,A2+1)<"" AND 十字架(,"");
DRAWTEXT(B2,),COLORFF00FF;{KDJ底离经叛道的行为}
A3:=BARSLAST(参考文献(C)ROSS(“
RSI.RSI1″,””),1));
B3:=参考文献(C),A3+1)>C AND Rf(,A3+1)<"" AND 十字架(,"");
DRAWTEXT(B3>0,),COLOR0000FF;{RSI底离经叛道的行为}
C1:=BARSLAST(参考文献(C)ROSS(“”,””),1));
D1:=参考文献(C),C1+1)“” AND 十字架(,””);
DRAWTEXT(D1>0,H+),COLOR00FF00;{MACD顶离经叛道的行为}
C2:=BARSLAST(参考文献(C)ROSS(“”,””),1));
D2:=参考文献(C),C2+1)“” AND 十字架(,””);
DRAWTEXT(D2>0,H+),COLORFFFFCC;{KDJ顶离经叛道的行为}
C3:=BARSLAST(参考文献(C)ROSS(“”,””),1));
D3:=参考文献(C),C3+1)“” AND 十字架(,””);
DRAWTEXT(D3>0,H+),COLORFF9900;{RSI顶离经叛道的行为};

STICKLINE(C>参考文献(C),1),H,L,0,1),COLOR0000FF;
STICKLINE(C>参考文献(C),1),O,C,),COLOR000055;
STICKLINE(C>参考文献(C),1),O,C,),COLOR000077;
STICKLINE(C>参考文献(C),1),O,C,),COLOR000099;
STICKLINE(C>参考文献(C),1),O,C,),COLOR0000BB;
STICKLINE(C>参考文献(C),1),O,C,),COLOR0000DD;
STICKLINE(C<参考文献(C),1),O,C,),COLOR0000FF;
STICKLINE(C<参考文献(C),1),H,L,0,1),COLORFFFF00;
STICKLINE(C<参考文献(C),1),O,C,),COLOR990000;
STICKLINE(C<参考文献(C),1),O,C,),COLORCC0000;
STICKLINE(C<参考文献(C),1),O,C,),COLORFF4400;
STICKLINE(C<参考文献(C),1),O,C,),COLORFF8800;
STICKLINE(C<参考文献(C),1),O,C,),COLORFFCC00;
STICKLINE(C<参考文献(C),1),O,C,),COLORFFFF00;
STICKLINE(C=参考文献(C),1),H,L,0,1),COLORFFFFFF;
STICKLINE(C=参考文献(C),1),O,C,),COLOR555555;
STICKLINE(C=参考文献(C),1),O,C,),COLOR777777;
STICKLINE(C=参考文献(C),1),O,C,),COLOR999999;
STICKLINE(C=参考文献(C),1),O,C,),COLORBBBBBB;
STICKLINE(C=参考文献(C),1),O,C,),COLORDDDDDD;
STICKLINE(C=参考文献(C),1),O,C,),COLORFFFFFF; 

主图定额准则1 - 来生缘 - 来生缘

 
主图定额准则1 - 来生缘 - 来生缘

次要准则为4的指数的准则。连结

MA1:马(C),2)COLORWHITE,LINETHICK2;
MA2:马(C),8)COLORYELLOW,LINETHICK2;
RSV:=(逼近)LLV(低),9)/(HHV(高),9)-LLV(低),9))*100;
K= SMA(RSV),3,1);
Y:=
VOL买:=CROSS(MA1,MA2);
价买:=C>MA1;
无足轻重的人:DRAWICON(K)<40 AND 价买 AND CROSS(MA1,MA2) AND Y),);
B买:DRAWICON((CROSS(C,马(C),3)) AND C<马(C),20) AND CLOSE>OPEN AND Y),);
金交叉期:DRAWICON((CROSS(MA1,MA2) AND CLOSE>OPEN),L-5,25);
卖:=CROSS(MA2,MA1);
需求:S卖:DRAWICON((CROSS(马(C),3),C) AND C<马(C),4) AND CLOSE

主图定额准则1 - 来生缘 - 来生缘

5.买卖趋向                                 

VAR1:=(C+H+O+L)/4;
需求:XMA(VAR1),N)*(1+P1/1000),COLORGREEN,LINETHICK2;
购买行为:XMA(VAR1),M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
扣押:100 *(平均水平-买进)/买进,NODRAW;
MA1:=MA(VAR1,3);
贴线(卖低) AND 平均水平贴线(卖> min(c),O) AND 平均水平贴线(卖低) AND 平均水平STICKLINE(平均水平STICKLINE(平均水平贴线(买低) AND 买进联系线(买> min(c),O) AND 买进贴线(买低) AND 买进贴线(买奢侈),OPEN,CLOSE,3,0),COLORMAGENTA;
贴线(买奢侈),HIGH,LOW,0,0),COLORMAGENTA;
字形(十字),购买行为),LOW*,买,COLORRED,LINETHICK2;
DRAWTEXT(CROSS(平均水平,高),HIGH*,卖,COLORGREEN; 

均线主图主图 - 来生缘 - 来生缘

6.买卖区间                                   

买线:=E马(C),2);
需求线:= EMA(斜率(C)),21)*20+C,42);
分成小方格以便复制的图形(买进线>平均水平线,重排(HHV),0),日期),重述(LLV)(L),0),日期),6,0),COLOR001050;
贴线(购买行为线)<卖线,重排(HHV),0),日期),重述(LLV)(L),0),日期),6,0),COLOR404050;
DRAWKLINE(H,O,L,C);
直系的:=EMA((E马(C)LOSE,4)+E马(C)LOSE,6)+E马(C)LOSE,12)+E马(C)LOSE,24))/4,2);
界:=马(C)LOSE,27);
B购买行为:以防(穿插),界) OR 穿插(购买行为线),卖线),C,DRAWNULL),COLORMAGENTA,NODRAW;
迷住:(买进线>平均水平线,C,DRAWNULL),COLORRED,NODRAW;
需求:(穿插),直系的) OR 穿插(需求线),购买行为线),C,DRAWNULL),COLORLIGRAY,NODRAW;
空以一定间隔排列:以防(买线)<卖线,C,DRAWNULL),COLORGREEN,NODRAW;
DRAWICON(穿插(购买行为线),卖线),L,1);
DRAWICON(穿插(需求线),购买行为线),H,2);                      

均线主图主图 - 来生缘 - 来生缘

7.不忿头不忿尾的准则执意好                     

JHH:HHV(C),2);
JRL: = LLV(C),2);
MA3:=马(C)LOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+高)/6;
R1:=(CLOSE>参考文献(C)LOSE,1) AND CLOSE>参考文献(C)LOSE,2));
R2=(REF)(R1),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R3=(REF)(R2),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R4=(REF)(R3),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R5:=(REF)(R4),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R6:=(REF)(R5),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R7:=(REF)(R6),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R8:=(REF(R7,1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R9:=(REF(R8,1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
Ra=(Rf)(R9),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
RB=(RF(RA),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
RC=(REF)(RB),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
RD =(逼近)<参考文献(C)LOSE,1) AND CLOSE<参考文献(C)LOSE,2));
RE:=(REF)(RD),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
Rf=(REF),1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R10:=(REF(RF),1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R11:=(REF(R10,1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R12:=(REF(R11,1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R13:=(REF(R12,1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R14:=(REF(R13,1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R15:=(REF(R14,1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R16:=(REF(R15,1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R17:=(REF(R16,1) AND CLOSE<=参考文献(C)LOSE,1) AND CLOSE>=参考文献(C)LOSE,2));
R18:=(REF(R17,1) AND CLOSE>=参考文献(C)LOSE,1) AND CLOSE<=参考文献(C)LOSE,2));
R19=REF(RD) OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A: =((REF)(R1) OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD)
VAR3: = IF(C)<200 ,马(C)OST(80),3),2500),NODRAW;
VAR4:=(((HIGH + 低) + 逼近) / 3);
VAR5:= EMA() + 高) + 低) + 逼近) / 4),2330);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));
弹簧购买行为:= R19,NODRAW,COLOR00DD00;
春季假期:= R1A,NODRAW,COLOR2288EE;
红股:= R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
郁闷:= RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,NODRAW,COLOR999999;
很快地超跌关怀:=(CLOSE-马(C)LOSE,34))/马(C)LOSE,34)*100<-14,COLORBBBBBB,NODRAW;
分开(=)(红股),JRL,DRAWNULL);
分开价钱=分开场子,COLORFF99FF,NODRAW;
现时的动身价钱:= REF(分开接防),1)COLOR0000FF,NODRAW;
进:=IF(郁闷),JRH,DRAWNULL);
进入价钱:=进入,COLOR33AACC,NODRAW;
现行入场权价:,1),COLOR00FF00,NODRAW;
STICKLINE(ISLASTBAR AND (红股) OR REF(红股),1)=1),现行保持一定距离价钱,现行保持一定距离价钱,20,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (郁闷) OR REF(郁闷),1)=1),现行入场权价钱,现行入场权价钱,20,1),COLOR00FF00;
XX2:EMA(EMA((CLOSE+LOW+高)/3,3),23),COLORGREEN, LINETHICK2;
XX3:=REF(XX2,1);
IF(XX2>XX3,XX2,DRAWNULL),COLORRED, LINETHICK2;
B11:=马(C)LOSE,1);
B22:SMA(SMA)(B11),2,1),2,1),2,1) ;
SMA2:=MA(B22,3) ;
DRAWBAND(B22,RGB(255,0,0),SMA2,RGB(0),255,0));
下线:((逼近) – 低电平(低电平),13)) / (HHV(高),13) – 低电平(低电平),13))) * 100);
RRSV:= SMA(下齿轮线),3,1);
KKK: = SMA(RRSV),3,1);
DDDDD:=((3 * RRRSV) – (2 * KKK)
JJ12:=(((CLOSE – 低电平(低电平),55)) / (HHV(高),55) – 低电平(低电平),55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) – (2 * K24));
压力2:= IF(穿插(D24)),DDDDD),HIGH,REF(高),BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
基础:= LLV(高),30),COLOR00FF00;
压力座位置置:,压力2,DRAWNULL),NODRAW;
基础:IF(ILSTSTAR),基础,DRAWNULL),NODRAW;
STICKLINE(ISLASTBAR ,压力座位置,压力座位置,40,0),COLORFF00FF,LINETHICK2;
STICKLINE(ISLASTBAR ,基础位,基础位,35,0),COLOR00FFFF,LINETHICK2;
B1:=参考文献(C)LOSE,1);
B2:=参考文献(C)LOSE,2);
B3:=参考文献(C)LOSE,3);
B4:=参考文献(C)LOSE,4);
Cmax:= max(评分斯(max)(关闭),B1),B2),B3)
min(min(min)(在附近),B1),B2),B3)
持股:=(CLOSE=CMAX AND (B1>=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR
(B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);
STICKLINE(持股,B1,CLOSE,3,0),COLOR000099;
变盘:=CLOSE=CMAX AND B1=CMIN;
贴线(易变的东西磁盘),B2,CLOSE,3,0),COLOR0099EF;
下跌:=(CLOSE=CMIN AND (B1(B2=CMIN AND B3=CMAX AND CLOSESTICKLINE(下跌,B1,CLOSE,3,0),COLOR009900;
STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,3,0),COLOR009900;
买进:=(B1=CMIN AND CLOSE>=B2) OR ((B2=CMIN AND B1<=B3) OR
(B3=CMIN AND B1<=B2) AND B2=B1);
人造丝线(买买),B1,B2,3,0),COLOR00FFFF;
兜售:=(B1=CMAX AND CLOSEB3) OR
(B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSE贴线(变卖财产),B1,B2,3,0),COLORFFFFFF;
STICKLINE(C>=O,L,H,0,1),COLORRED;
STICKLINE(CSTICKLINE(持股 OR 买进,O,C,),COLORRED;
STICKLINE(下跌 OR 兜售,O,C,),COLORGREEN;
STICKLINE(C>0,O,C,0,0),COLORFFFFFF;
MMA:=const(HHV(H),90));
MMB: = const(LLV(L),90));
WN:=3;{原代码 N:=3;}
WA1:=REF(H),WH= HHV(H),2*WN+1); WB1:=FILTER(WA1,WN) WC1:=BACKSET(WB1,WN+1); WD1:=FILTER(WC1,WN){高点}
WA2: = REF(L),WL= LLV(L),2*WN+1); WB2:=FILTER(WA2,WN) WC2: =反向集(WB2),WN+1); WD2:=滤网(WC2),WN){低点}
WE1: =(REF(LLV)(L),2*WN),1)+REF(HHV(H,2*WN),1))/2;
WE2:=(H+L)/2;{高低点出现时类似K线上时可作取舍}
WH1:=(WD1 AND NOT(WD2 AND WE1>=WE2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
WL1:=(WD2 AND NOT(WD1 AND WE1=WE2);
WX1: = REF(BASSREST(WH1)),1)+1; WF1: =回退(WH1) AND COUNT(WL1,WX1)> 0,LLVBARS(IF(WL1,L,10000),WX1)
WG1:=WF1>REF(WF1,1); WI1:=BACKSET(WG1,2); WLD:=WI1>REF(WI1,1);{{过滤低点}以后
WL2:=WLD OR ISLASTBAR OR BARSCOUNT(C)=1;
WX2:=REF(BARSLAST(WL2),1)+1; WF2:=BACKSET(WL2 AND COUNT(WH2,WX2)>0,HHVBARS(IF(WH2,H,0),WX2));
WG2:=WF2>REF(WF2,1); Wi2:=反向集(WG2),2); WHD:=WI2>REF(WI2,1);{滤波后的高点}
WR1:=BACKSET(ISLASTBAR,巴尔斯末(WHD) 1) WS1:=WR1>REF(WR1,1); {高音的高}
WT1: =回退(ISLASTAR),巴尔斯末(WLD) 1) WU1:=WT1>REF(WT1,1); {高音的低}
WR1 =反向集(WS1),巴斯末(WHD),1)+2); WS2:=WR2>REF(WR2,1); {前两个高}
WT2:=BACKSET(WU1,巴斯末(WLD),1)+2); 武2:=WT2>REF(WT2,1); {前两个低}
WT3: =背靠背(武2),巴斯末(WLD),1)+2); 吴三:=WT3>REF(WT3,1); {前三低}
WT4: =背靠背(吴三),巴斯末(WLD),1)+2); WU4:=WT4>REF(WT4,1); {前四低}
WR2 = WSET(WS2),巴斯末(WHD),1)+2); WS3:=WR3>REF(WR3,1); {前三名高}
WR4:=BACKSET(WS3,巴斯末(WHD),1)+2); WS4:=WR4>REF(WR4,1); {前四名高}
压力1:=拉线(WS2),H,WS1,H,1),COLOR008888; 压力1
忍受1:=拉线(武2),L,WU1,L,1),Celo900888;{忍受1
压力2:=拉线(WS3),H,WS2,H,1),COLOR888000; 压力2
忍受2:=拉线(吴三),L,武2,L,1),Celo88000;{忍受2
压力3:=拉线(WS4),H,WS3,H,1),Copy0.00 CC;{**压力3
忍受3:=拉线(WU4),L,吴三,L,1),Celp0.00 CC;{]忍受3
BSC=const(max)(BsScript(WS4)),BARSLAST(WU4))*3),NODRAW;
以防(在1暗中),MMA,MMB),压力1,DRAWNULL),COLOR008888,LINETHICK1;
以防(在1暗中),MMA,MMB),忍受1,DRAWNULL),COLOR008888,LINETHICK1;
以防(在2暗中),MMA,MMB),压力2,DRAWNULL),COLOR888000,LINETHICK1;
以防(在2暗中),MMA,MMB),忍受2,DRAWNULL),COLOR888000,LINETHICK1;
以防(在3暗中),MMA,MMB),压力3,DRAWNULL),COLOR0000CC,LINETHICK1;
以防(在3暗中),MMA,MMB),忍受3,DRAWNULL),COLOR0000CC,LINETHICK1;
底:=SUM(马(C)LOSE,10),9)/114;